صدور تحديث لبيئة سطح المكتب KDE 5.3.1

kde-plasma-5.3

صدر تحديث جديد لبيئة سطح المكتب العريقة kde خلال اﻷيام القليلة الماضية رقم 3.5.1 وهو إصدار صيانة حمل أكثر من 112 تغيير شمل تحسين الميزات وحل العلل والأخطاء وفي هذه المقالة نستعرض طريقة التثبيت والتحديث بالإضافة إلى ذكر أبرز التغييرات.

  • إصلاح مشكلة موضع صندوق الأدوات.
  • إصلاح مشكلة الترجمة للعبارات الموجودة في kcm/touchpad.kcfg.
  • إزالة البروكسي الزائد عن الحاجة.
  • إصلاح ظهور الخطوط العمودية.
  • إصلاح مشكلة التمرير العكسي في فأرة KCM.
  • حلّ مشكلة عدم إغلاق الأقسام الأخيرة عند التفريغ.
  • ضبط هوامش الألواح العمودية كما في الأفقية.
  • حلّ مشكلة عدم فتح قائمة الإجرائات مرتان.
  • إصلاح مشكلة في خيار “اضافة الى سطح المكتب”
  • SQLite يدعم الإزاحة فقد عندما يتم تعيين الحد.
  • تنظيف بعض المصححات الغير مرغوب فيه.
  • تحسين رؤية العناصر المفعلة.
  • إصّلاح مشكلة في تشغيل عنصر الحاسبة من القائمة.
  • حلّ مشكلة في التحقق من وجود موديول.
  • حلّ مشكلة في إعادة تشغيل المؤقت الزمني.
  • حلّ مشكلة عدم تبديل مساحة العمل في حالة تحجيم النوافذ.
  • حلّ خطآن في الإضافات.
  • تحديث ملف pin-code-database.xml.
  • إضافة خيار إظهار/ إخفاء لشريط القوائم.
  • حل مشكلة متعلقة بالترتيب الافتراضي لسطح المكتب.
  • تحّسين عرض زرّ التحديث في مثبت التطبيقات muno.
  • والعديد من الاصلاحات والتحسينات الكثيرة حقيقةً والتي يمكنكم الإطلاع عليها من خلال الرابط التالي

 

طريقة التثبيت والتحديث على التوزيعات الدبيانية (أوبونتو – كوبونتو – لينكس مينت) من الطرفية أدخل الأوامر التالية :

sudo apt-get build-dep qtbase5-dev

sudo apt-get install libbz2-dev libxslt-dev libxml2-dev shared-mime-info oxygen-icon-theme libgif-dev libvlc-dev libvlccore-dev doxygen gperf bzr libxapian-dev fontforge libgcrypt20-dev libattr1-dev network-manager-dev libgtk-3-dev xsltproc xserver-xorg-dev xserver-xorg-input-synaptics-dev libpwquality-dev modemmanager-dev libxcb-keysyms1-dev libepoxy-dev libpolkit-agent-1-dev libnm-util-dev libnm-glib-dev libegl-mesa-dev libxcb-xkb-dev libqt5x11extras5-dev libwww-perl libxml-parser-perl libjson-perl libboost1.55-dev libgstreamer-plugins-base1.0-dev libgstreamer1.0-dev

للتثبيت والتحديث على توزيعة فيدورا من الطرفية أدخل الأوامر التالية :

sudo yum-builddep qt phonon-backend-vlc phonon-backend-gstreamer

sudo yum install gcc-c++ ruby doxygen git bzr flex bison gperf socat boost-devel bzip2-devel libxslt-devel libxml2-devel shared-mime-info oxygen-icon-theme giflib-devel xcb-util-keysyms-devel perl-JSON perl-Pod-Usage “*xcb*-devel” perl-XML-Parser NetworkManager-glib-devel xapian-core-devel libxkbcommon-devel libxkbcommon-x11-devel  systemd-devel libwayland-cursor-devel libwayland-server-devel libepoxy-devel gtk3-devel sane-backends-devel libattr-devel libcanberra-devel libusb-devel libxkbfile-devel fontforge-devel libical-devel gpgme-devel cyrus-sasl-devel openldap-devel libpwquality-devel polkit-devel

 

للتثبيت والتحديث على توزيعة آرتش ومابني عليها من الطرفية أدخل الأوامر التالية :

sudo pacman -Sy phonon-qt5 qt5-webkit qt5-script qt5-svg qt5-tools qt5-x11extras enchant jasper openexr libutempter docbook-xsl shared-mime-info giflib libxss upower udisks2 bzr git doxygen perl-json perl-libwww

<your_AUR_helper> kf5-akonadi-git

ستحتاج لإعادة التشغيل ومن ثم تثبيت التحديثات حتى يكتمل التثبيت…

[media-opensource]

  • khalidzuhd

    عندي مشكلة بمنت 17 .1 انو ما بترضى تنزل عليها كادي 5

    • Rdwan Hlak

      هل هناك رسالة خطأ ؟

      • khalidzuhd

        للاسف جاسون ارور
        ما بتعرف ع المخازن

مشاركة